[Préparation des rushes] Glitch/Couleur modifié

Résoudre un problème, apprendre comment créer un AMV, se perfectionner et découvrir de nouvelles techniques, consulter les tutoriels
Avatar de l’utilisateur
††_Otto 974_††
Messages : 196
Inscription : jeu. 2 oct. 2008 18:14
Localisation : Ile de la Reunion
Contact :

[Préparation des rushes] Glitch/Couleur modifié

Messagepar ††_Otto 974_†† » jeu. 7 nov. 2013 14:45

Bonjour,

En ce moment je cherche à créer mes rush pour pouvoir ensuite les utiliser sous Premier Pro mais j'ai un problème de rendu.

Les caractéristiques de ma source sont (relevé sur vlc):
47.952047fps
Résolution:1920x1080
Codec: H264-MPEG-4
Format décodé: Planar 4:2:0 YUV 10-bit (Espace couleur YV12)
Conteneur: .mkv


J'importe dans VDubMod le script avs suivant:
DirectShowSource("C:\...[]...mkv")
KillAudio
ChangeFPS(23.976)
BicubicResize(1920,1080)
ConvertToYV12
SangNom(order=1,aa=20)
UnDot()


Ensuite je voulais utiliser le codec lagarith pour pas avoir de perte mais quand j'importe mon rush sous Premier j'ai une vidéo noir. Pourtant quand je lit cette vidéo avec VLC j'ai pas cette vidéo noir. J'ai bien quelque chose.

Le lagarith ne marchant pas j'ai essayé le codec Huffyuv et DivX (profil HQ1080) pour mon rush. Et la, dans Premier ou avec VLC je vois que mon image est "sale". Y'a plein de glitch/déformation. Dans l'image ci dessous j'ai fait une comparaison entre la vidéo source et ensuite mon rush
Spoil : Afficher
Image


Je ne comprend pas du tout c'est du à quoi. J'aimerais avoir des rush propres que j'utiliserai pour clipper. Comment faire ?

Merci d'avance pour votre aide :)
Image

Avatar de l’utilisateur
††_Otto 974_††
Messages : 196
Inscription : jeu. 2 oct. 2008 18:14
Localisation : Ile de la Reunion
Contact :

Re: [Préparation des rushes] Glitch/Couleur modifié

Messagepar ††_Otto 974_†† » ven. 8 nov. 2013 07:27

En faite dès que j'importe sous Vdub mon script avs de base j'observe un problème de qualité
DirectShowSource("C:\...[]...mkv")


Image:
Spoil : Afficher
Image
Image

Avatar de l’utilisateur
MagicDarkLight
Membre AMV-France
Messages : 2187
Inscription : mer. 5 août 2009 01:00
Localisation : BELGIQUE
Contact :

Re: [Préparation des rushes] Glitch/Couleur modifié

Messagepar MagicDarkLight » ven. 8 nov. 2013 15:18

Salut,

Ca me fait penser à un souci de codec, ta source est surement encodée en 10bits et vdub a du mal à le lire correctement avec tes codecs actuels. Donc je te conseille de ddl la dernière version du pack cccp. Apres ça n'a peut-être rien à voir :p Mais en gros, mets tes codecs à jour.
Image
Image
Image

Avatar de l’utilisateur
kain-x-spirits
Messages : 2764
Inscription : dim. 24 août 2008 23:50
Localisation : Caen
Contact :

Re: [Préparation des rushes] Glitch/Couleur modifié

Messagepar kain-x-spirits » ven. 8 nov. 2013 19:33

††_Otto 974_†† a écrit :
10-bit


Donc change ça :
††_Otto 974_†† a écrit :
DirectShowSource("C:\...[]...mkv")

Utilise ffvideosource(): post121610.html?hilit=ffvideosource#p121610
"I am the white void. I am the cold steel. I am the just sword. With blade in hand shall I reap the sins of this world, and cleanse it in the fires of destruction."

Avatar de l’utilisateur
††_Otto 974_††
Messages : 196
Inscription : jeu. 2 oct. 2008 18:14
Localisation : Ile de la Reunion
Contact :

Re: [Préparation des rushes] Glitch/Couleur modifié

Messagepar ††_Otto 974_†† » sam. 9 nov. 2013 05:32

Ca me fait penser à un souci de codec, ta source est surement encodée en 10bits et vdub a du mal à le lire correctement avec tes codecs actuels. Donc je te conseille de ddl la dernière version du pack cccp.


Merci pour ta réponse MagicDarkLight. Les codecs, le casse tête absolue^^ J'ai fait une installation complète de mes codecs en utilisant la dernière version du pack cccp y'a une semaine de ca donc normalement tout est à jour.

Utilise ffvideosource()


Merci aussi pour ta réponse kain-x-spirits . Ca marche N-I-C-K-E-L
J'avais peu d'espoir au début parce que VDub crasher avant d'avoir réussi à importer la vidéo, mais avec de la patience il finit par y arriver. C'est normal que ce plugin maltraite autant mon ordi/VDub ?

Encore merci à vous deux :)
Dernière édition par ††_Otto 974_†† le sam. 9 nov. 2013 08:43, édité 1 fois.
Image

Avatar de l’utilisateur
kain-x-spirits
Messages : 2764
Inscription : dim. 24 août 2008 23:50
Localisation : Caen
Contact :

Re: [Préparation des rushes] Glitch/Couleur modifié

Messagepar kain-x-spirits » sam. 9 nov. 2013 07:30

Oui c'est normal. FFmpegsource doit "indexer" ta vidéo et si tu as un ordi pas très puissant ca peut prendre un peu de temps. Ou bien si la vidéo est assez longue(pour un film par exemple), ça risque de prendre plus de temps. T'auras l'impression que Vdub ne répond plus, mais enfaite t'as juste à attendre un petit instant.
Par contre s'il crash (avec un message d'erreur ou bien s'il se ferme tout seul), c'est pas normal.
"I am the white void. I am the cold steel. I am the just sword. With blade in hand shall I reap the sins of this world, and cleanse it in the fires of destruction."

Avatar de l’utilisateur
††_Otto 974_††
Messages : 196
Inscription : jeu. 2 oct. 2008 18:14
Localisation : Ile de la Reunion
Contact :

Re: [Préparation des rushes] Glitch/Couleur modifié

Messagepar ††_Otto 974_†† » dim. 10 nov. 2013 16:07

Salut à tous,

Je reviens pour encore un peu d'aide :p
J'ai fait plusieurs essais avec le lagarith/huffyuv et j'arrive à un résultat que je ne comprends pas et me gêne.
J'ai fait une liste de mes différentes configuration:
1/ HuffYUV [Dans le panneau configurer j'ai choisi ConvertToYUY2 car ma source de basse est en YUY(YV12)et parce que le RGB donnera un fichier plus lourd)]->1.62 Go

2/ Lagarith [Configurer->Mode RGB]->1.41Go

3/ Lagarith [Configurer->Mode YUY2]->862Mo

4/ Lagarith [Configurer->Mode YV12]->773Mo



Au départ je voulais utiliser la configuration 4 car c'est celle qui me donne un fichier moins lourd et que, ma source étant en YV12, je n'aurai pas perdu de donné en convertissant dans un autre espace couleur. Malheureusement PremierPro m'affiche une vidéo noir. C'est la même chose avec la configuration 3. PremierPro ne supporte pas mes vidéo en Lagarith YUV(YV12/YUY2). C'est bizarre car il devrait. D'ailleurs certain effet de PP sont même optimisé pour le YUV. Au début j'avais pensé que c’était le codec lagarith qui posait problème mais PP n'a aucun problème avec la configuration 2 en RGB.

Quand au Huyyuv, il marche bien même si il est configuré en YUV.

Pourquoi ma configuration 3 et 4 ne marchent elles pas ?
Quels sont les désavantages/avantages si je passe en Laga RGB à partir de ma source en YV12?
Et y'a t'il une différence de Workflow sur PP quand on travail avec des sources en RGB ou YUY ?

Je me pose aussi la question si je me prends pas trop le choux avec cette histoire d'espace couleur car il n'influence que très peu la qualité final de ma vidéo lol
Image


Revenir vers « Aide - Tutos - Résolution de problèmes »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités